Knowledgebase
Cornerstone fails to start after upgrade to version 8.4 (Affects Titan MFT 7 customers)
Posted by Ta Baker on 06 October 2011 07:32 PM
Problem:

Existing Titan 7 MFT customers configured with a DMZedge server who upgrade to Cornerstone version 8.4 will get an error when trying to start the server. Customers may see the following error message: "Base Services failed to start" followed by references to SQL and creating DMZedge tables. In the Cornerstone Console, this error will appear: "Error starting the server. Make sure that there are no port conflicts - check the logfile for details"

Cause:

In earlier versions of MFT (Titan 7), customers could elect to store configuration settings in the Registry or an ODBC database. With Cornerstone, the configuration is now stored only in SQL; however, to maintain support for existing customers, Development allowed Registry-based configurations to upgrade to Cornerstone 8 without forcing migration to a SQL database. With the addition of new features in Cornerstone 8.3 to include a more robust DMZedge module, the product relies on the existence of SQL tables during the upgrade/install of the product.

Fix:

To resolve the above error, customers need to use the built-in Server migration utility in the CS 8.4 Admin console to migrate their Registry based configuration to a SQL (ODBC/DB) table prior to upgrading to Cornerstone 8.4 or higher. After upgrading, go to the DMZedge Tab in the CS Administrator for their server and re-configure their DMZedge Server settings.

How to use the Server Migration Utility:

1. In the Titan Admin Console, highlight the existing FTP server, then from the menu, select Server| Migrate Server. This will launch the Migration Wizard. Use the dropdown box to “select the SQL Server instance.” Cornerstone will create a SQL Database name for you automatically. Depending on the authentication method for your SQL database, you can select either Windows authentication or SQL authentication. If you select SQL Authentication, you will need to enter your credentials in the fields provided. Click on the Test button to establish a connection to the SQL server. If it fails, you will need to check your connectivity to the SQL server. Once you have successfully tested the connection, click on the Next button to create the database. On the final step, click the Migrate button to move your configuration to the SQL database.

NOTE: If you are using Windows authentication, you will need to use a Domain account that has access to the remote SQL server and has the ability to create tables. Please check with your DBA prior to the start of the migration. This domain account must be configured to launch the Cornerstone service as well. Contact SRT Tech Support for more information on this setup. http://srthelpdesk.helpserve.com/.

2. When the migration completes, your server should appear online in the Admin console window. Once your server has been migrated to SQL, you can continue to migrate your Registry based servers using the same steps.


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